坑爹水題——Uva10036

題目鏈接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=&problem=976&mosmsg=Submission+received+with+ID+11932248

Problem B: Primary Arithmetic

Children are taught to add multi-digit numbers from right-to-left onedigit at a time. Many find the "carry" operation - in which a 1 iscarried from one digit position to be added to the next - to bea significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so thateducators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations thatwould result from adding the two numbers, in the formatshown below.

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.



當答案爲1 和大於1時,輸出時不同的。。。。




#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    unsigned int  a,b,c,ans;
    while(cin>>a>>b){
        if(a==0&&b==0)
            break;

        c=ans=0;
        while(a!=0 || b!=0 ){
            c+=a%10 + b%10;
            a/=10;
            b/=10;
            if(c>9){
               ans++;
            }
            c/=10;
        }
        if(ans==0)
            cout<<"No carry operation."<<endl;
        else if(ans==1)
            cout<<"1 carry operation.\n";
        else
            printf("%d carry operations.\n",ans);

    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章