並查集之POJ--1308--Is It A Tree?


Is It A Tree?
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 34308   Accepted: 11630

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

貌似可以用多種方法解,然而菜雞知識尚淺,只能用暑假學的並查集給水過去了/(ㄒoㄒ)/~~-------
並查集通俗的說就是不相交的數據結構!本題只需在合併數據之前判斷下兩個節點是否有同一個祖先,如果有同一祖先,說明兩節點
之間已有一條路徑,那麼這就不是一棵“Tree”!最後遍歷原數組是否有且只有一個集合即可。附代碼:

#include<stdio.h>
#include<string.h>
int f[1000001];
struct ss
{
    int xx,yy;
}s[1000001];
int B(int z)
{
    if(f[z]==z)
        return z;
    else
    {
        f[z]=B(f[z]);
        return f[z];
    }
}
void A(int x1,int y1)
{
   int t1=B(x1);
   int t2=B(y1);
   if(t1!=t2)
    f[t2]=t1;
}
int main()
{
    int q=1;
    while(true)
    {
        int x,y;
        int p=0,max1=0;
        memset(f,0,sizeof(f));
    while(scanf("%d%d",&x,&y)!=EOF)
    {
        if(x==-1&&y==-1)
           return 0;
       else if(x==0&&y==0)
            break;
       else
       {
           s[p].xx=x;
           s[p].yy=y;
           f[x]=x;
           f[y]=y;//這裏只需初始化出現的數據
           if(x>max1)
            max1=x;
           if(y>max1)
            max1=y;
            p++;
       }
    }
    int t=0;
    for(int i=0;i<p;i++)
    {
        if(B(s[i].xx)==B(s[i].yy))
        {
            t=1;
            break;
        }
        else
            A(s[i].xx,s[i].yy);
    }
    int sum=0;
    for(int i=1;i<=max1;i++)
        if(f[i]==i)
            sum++;
    if(p==0)
          printf("Case %d is a tree.\n",q);
    else if(sum==1&&t==0)
    printf("Case %d is a tree.\n",q);
    else
    printf("Case %d is not a tree.\n",q);
    q++;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章