uva 10168 summation of four primes

Problem A

Summation of Four Primes

Input: standard input

Output: standard output

Time Limit: 4 seconds

 

Euler proved in one of his classic theorems that prime numbers are infinite in number. But can every number be expressed as a summation of four positive primes? I don’t know the answer. May be you can help!!! I want your solution to be very efficient as I have a 386 machine at home. But the time limit specified above is for a Pentium III 800 machine. The definition of prime number for this problem is “A prime number is a positive number which has exactly two distinct integer factors”. As for example 37 is prime as it has exactly two distinct integer factors 37 and 1.

 

Input

The input contains one integer number N (N<=10000000) in every line. This is the number you will have to express as a summation of four primes. Input is terminated by end of file.

 

Output

For each line of input there is one line of output, which contains four prime numbers according to the given condition. If the number cannot be expressed as a summation of four prime numbers print the line “Impossible.” in a single line. There can be multiple solutions. Any good solution will be accepted.

 

Sample Input:

24
36
46

 

Sample Output:

3 11 3 7
3 7 13 13
11 11 17 7


Shahriar Manzoor

“You can fool some people all the time, all the people some of the

time but you cannot fool all the people all the time.”




看別人的,哥德巴赫猜想!


#include <cstdio>
#include <cstring>
#include <cassert>
#include <cstdlib>

#ifndef ONLINE_JUDGE
#define debug_printf(...) (printf(__VA_ARGS__))
#else
#define debug_printf(...) (0)
#endif

const int PRIME_SZ_MAX = 10000000;

bool is_prime[PRIME_SZ_MAX];

int prime[PRIME_SZ_MAX / 2];
int prime_sz;

void generate_primes()
{
    memset (is_prime, 1, sizeof (is_prime));
    for (int i=2; i<PRIME_SZ_MAX; ++i) {
        for (int k=i+i; is_prime[i] && k<PRIME_SZ_MAX; k+=i) {
            is_prime[k] = false;
        }
    }

    prime_sz = 0;
    for (int i=2; i<PRIME_SZ_MAX; ++i) {
        if (is_prime[i]) {
            prime[prime_sz++] = i;
        }
    }
}

void solve()
{
    int n;
    if (scanf ("%d", &n) == EOF) {
        exit (0);
    }

    if (n < 8) {
        printf ("Impossible.\n");
        return;
    }

    int a, b, c, d;
    if (n % 2 == 1) {
        a = 2;
        b = 3;
    } else {
        a = 2;
        b = 2;
    }

    c = -1;
    d = -1;
    for (int i=0; i<prime_sz; ++i) {
        c = prime[i];
        d = n - a - b - c;
        if (is_prime[d]) {
            break;
        }
    }
    assert (c != -1 && d != -1);

    printf ("%d %d %d %d\n", a, b, c, d);
}

int main (int argc, char **argv)
{
    generate_primes();
    debug_printf ("Done!\n");
    debug_printf ("%d primes generated.\n", prime_sz);

    while (true) {
        solve();
    }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章