hdu 3363 ice sugar gourd

Ice-sugar Gourd

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 568    Accepted Submission(s): 207


Problem Description
Ice-sugar gourd, “bing tang hu lu”, is a popular snack in Beijing of China. It is made of some fruits threaded by a stick. The complicated feeling will be like a both sour and sweet ice when you taste it. You are making your mouth water, aren’t you?

I have made a huge ice-sugar gourd by two kinds of fruit, hawthorn and tangerine, in no particular order. Since I want to share it with two of my friends, Felicia and his girl friend, I need to get an equal cut of the hawthorns and tangerines. How many times will I have to cut the stick so that each of my friends gets half the hawthorns and half the tangerines? Please notice that you can only cut the stick between two adjacent fruits, that you cannot cut a fruit in half as this fruit would be no good to eat.
 

Input
The input consists of multiply test cases. The first line of each test case contains an integer, n(1 <= n <= 100000), indicating the number of the fruits on the stick. The next line consists of a string with length n, which contains only ‘H’ (means hawthorn) and ‘T’ (means tangerine).
The last test case is followed by a single line containing one zero.
 

Output
Output the minimum number of times that you need to cut the stick or “-1” if you cannot get an equal cut. If there is a solution, please output that cuts on the next line, separated by one space. If you cut the stick after the i-th (indexed from 1) fruit, then you should output number i to indicate this cut. If there are more than one solution, please take the minimum number of the leftist cut. If there is still a tie, then take the second, and so on.
 

Sample Input
4 HHTT 4 HTHT 4 HHHT 0
 

Sample Output
2 1 3 1 2 -1
 

Source
 

Recommend
lcy



貪心,切一次,或切兩次,枚舉切的位置。



#include <cstdio>
#include <cassert>
#include <cstring>
#include <cstdlib>

int main ()
{
    int n;
    while (scanf ("%d", &n) == 1 && n) {
        static char str[100010];
        scanf ("%s", str);
        if (n % 2 == 1) {
            printf ("-1\n");
            continue;
        }
        int h_tot = 0, t_tot = 0;
        for (int i=0; i<n; ++i) {
            if (str[i] == 'T')
                ++t_tot;
            else
                ++h_tot;
        }
        if (h_tot % 2 == 1 || t_tot % 2 == 1) {
            printf ("-1\n");
            continue;
        }
        int h = 0, t = 0;
        for (int i=0; i<n/2; ++i) {
            if (str[i] == 'T')
                ++t;
            else
                ++h;
        }
        if (t * 2 == t_tot && h * 2 == h_tot) {
            printf ("1\n%d\n", n / 2);
            continue;
        }
        for (int i=n/2; i<n; ++i) {
            if (str[i] == 'T')
                ++t;
            else
                ++h;
            if (str[i - n/2] == 'T')
                --t;
            else
                --h;
            if (t * 2 == t_tot && h * 2 == h_tot) {
                printf ("2\n%d %d\n", i + 1 - n/2, i + 1);
                break;
            } else if (i == n - 1) {
                printf ("-1\n");
            }
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章