1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
struct Person{
    char id[16];
    char signIn[10];
    char signOut[10];
};
int main()
{
    freopen("in.txt","r",stdin);
    int m;
    scanf("%d",&m);
    Person* p=new Person[m];
    for(int i=0;i<m;i++){
        scanf("%s %s %s",p[i].id,p[i].signIn,p[i].signOut);
    }
    //找出登錄時間最小的那個
    int minIndex=0;
    char* min=p[0].signIn;
    for(int i=1;i<m;i++){
        if(strcmp(p[i].signIn,min)<0){
            minIndex=i;
            min=p[i].signIn;
        }
    }
    //找出登出時間最大的那個
    int maxIndex=0;
    char* max=p[0].signOut;
    for(int i=1;i<m;i++){
        if(strcmp(p[i].signOut,max)>0){
            maxIndex=i;
            max=p[i].signOut;
        }
    }
    printf("%s %s",p[minIndex].id,p[maxIndex].id);
    return 0;
}

簡單的字符串比較,strcmp不能用-1,1來判斷二者大小,而要用大於0和小於0來判斷,否則有2個用例過不去

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章