HDU 1048 The Hardest Problem Ever

The Hardest Problem Ever

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29319    Accepted Submission(s): 13746

Problem Description

Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 

Cipher text
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text
V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 

A single data set has 3 components: 

Start line - A single line, "START" 

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 

End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT".

 

 

Output

For each data set, there will be exactly one line of output. This is the original message by Caesar.

 

 

Sample Input

START

NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX

END

START

N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ

END

START

IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ

END

ENDOFINPUT

 

 

Sample Output

IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES

I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME

DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

 

 

Source

South Central USA 2002

 

 

解題思路:

通過輸入STARTEND來控制輸入字符,我的想法是用string類定義一個字符串數組,並在開始判斷他是ENDOFINPUT還是START,並不用管END

不過要記住在輸入START結束後你會按下回車。

也就是如果不利用getchar();,會導致你的字符串還沒開始輸入就已經向其中輸入了一個結束符,這會讓你後來輸入的字符成爲無用功。

然後注意需要變換的A~E,只用往後移21位,F~Z只用往前移5位。然後END只要在輸出字符串前輸入一下就好了。

以下是我的AC代碼。


#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    char str[200];
    int len;
    string panduan;
    while(1)
    {
        memset(str, 0, 200);
        cin>>panduan;
        getchar();
        if(panduan[0] == 'S')
        {
            fgets(str, 200, stdin);
            len = strlen(str);
            for(int i = 0; i < len; i++)
            {
                if(str[i] >= 'A' && str[i] <= 'E')
                    str[i] += 21;
                else if(str[i] > 'E' && str[i] <= 'Z')
                    str[i] -= 5;
                else continue;
            }
            cin>>panduan;
            cout<<str;
        }
        else if(panduan[0] == 'E' && panduan[3] == 'O')
            break;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章