1129. Recommendation System

1129. Recommendation System (25)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

提交代

剛開始想的是每一輪都用sort排下序,結果超時,之後看了別人的題解發現要用set,而且我竟然才知道set可以通過結構體優先級設置來自己定義排序規則,之前用優先隊列的時候用過重載運算符,但是都忘了,算是今天又複習了一遍。附上代碼

#include<bits/stdc++.h>
using namespace std;
struct node{
    int v;
    int cnt;
    friend bool operator < (const node &x,const node &y){
        if(x.cnt!=y.cnt) return x.cnt>y.cnt;
        else return x.v<y.v;
    }
};
set<node>s;
int n,k,a[50005],visit[50005];
int main(){
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    node temp;
    for(int i=2;i<=n;i++){
        int x=a[i-1];
        if(!visit[x]){
            visit[x]=1;
            temp.v=x;temp.cnt=1;
            s.insert(temp);
        }else{
            for(auto it=s.begin();it!=s.end();it++){
                node now=*it;
                if(now.v==x){
                    temp.v=x;
                    temp.cnt=now.cnt+1;
                    s.erase(it);
                    s.insert(temp);
                    break;
                }
            }
        }
        printf("%d: ",a[i]);
        int l=s.size();
        int len=min(l,k);
        int j=1;
        for(auto it=s.begin();it!=s.end()&&j<=len;it++){
            node now=*it;
            printf("%d",now.v);
            if(j!=len)printf(" ");
            j++;
        }
        printf("\n");
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章