Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
InputThe input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
OutputFor each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13	
簡單的dfs,注意檢索位置要算上一個。
#include<iostream>
#include <cstring>
#include<string>
#include<cmath>
using namespace std;
char map[22][22];
int sum,v[22][22],m,n;
void dfs(int a,int b)
{
    sum++;
    v[a][b]=1;
    if ((map[a+1][b]=='.')&&(v[a+1][b]==0)&&((a+1)<=n)) dfs(a+1,b);
    if ((map[a-1][b]=='.')&&(v[a-1][b]==0)&&((a-1)>=1)) dfs(a-1,b);
    if ((map[a][b+1]=='.')&&(v[a][b+1]==0)&&((b+1)<=m)) dfs(a,b+1);
    if ((map[a][b-1]=='.')&&(v[a][b-1]==0)&&((b-1)>=1)) dfs(a,b-1);
}
int main()
{
    int i,j,a,b;
    char s[21];
    while(cin>>m>>n,m+n>0)
    {
        sum=0;
        memset(v,0,sizeof(v));
        for (i=1;i<=n;i++)
        {
            cin>>s;
            for (j=1;j<=m;j++)
            {
                map[i][j]=s[j-1];
                if (s[j-1]=='@')
                {
                    a=i;
                    b=j;
                }
            }
        }
        dfs(a,b);
        cout<<sum<<endl;
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章