蓝桥杯基础练习 报时助手

问题描述
  给定当前的时间,请用英文的读法将它读出来。
  时间用时h和分m表示,在英文的读法中,读一个时间的方法是:
  如果m为0,则将时读出来,然后加上“o'clock”,如3:00读作“three o'clock”。
  如果m不为0,则将时读出来,然后将分读出来,如5:30读作“five thirty”。
  时和分的读法使用的是英文数字的读法,其中0~20读作:
  0:zero, 1: one, 2:two, 3:three, 4:four, 5:five, 6:six, 7:seven, 8:eight, 9:nine, 10:ten, 11:eleven, 12:twelve, 13:thirteen, 14:fourteen, 15:fifteen, 16:sixteen, 17:seventeen, 18:eighteen, 19:nineteen, 20:twenty。
  30读作thirty,40读作forty,50读作fifty。
  对于大于20小于60的数字,首先读整十的数,然后再加上个位数。如31首先读30再加1的读法,读作“thirty one”。
  按上面的规则21:54读作“twenty one fifty four”,9:07读作“nine seven”,0:15读作“zero fifteen”。
输入格式
  输入包含两个非负整数h和m,表示时间的时和分。非零的数字前没有前导0。h小于24,m小于60。
输出格式
  输出时间时刻的英文。
样例输入
0 15
样例输出
zero fifteen

挺简单的,判断就行。
#include<stdio.h>
#include<cstring>
int main()
{
	char s[70][10];
	strcpy(s[0],"zero");strcpy(s[1],"one");strcpy(s[2],"two");strcpy(s[3],"three");strcpy(s[4],"four");
	strcpy(s[5],"five");strcpy(s[6],"six");strcpy(s[7],"seven");strcpy(s[8],"eight");strcpy(s[9],"nine");strcpy(s[10],"ten");
	strcpy(s[11],"eleven");strcpy(s[12],"twelve");strcpy(s[13],"thirteen");strcpy(s[14],"fourteen");strcpy(s[15],"fifteen");
	strcpy(s[16],"sixteen");strcpy(s[17],"seventeen");strcpy(s[18],"eighteen");strcpy(s[19],"nineteen");strcpy(s[20],"twenty");
	strcpy(s[30],"thirty");strcpy(s[40],"forty");strcpy(s[50],"fifty");strcpy(s[60],"sixty");
	int m,h,m1=0,h1=0,j=1;
	scanf("%d%d",&h,&m);
	if(m==0)
	j=0;
	if(m>20)
	{
		m1=m%10;m-=m1;
	}
	if(h>20)
	{
		h1=h%10;h/=10;h*=10;
	}
	//printf("h1 %d m1 %d h%d m%d\n",h1,m1,h,m);
		printf("%s ",s[h]);
	if(h1>0)
	printf("%s ",s[h1]);
	if(m!=0)	printf("%s ",s[m]);
	if(m1>0)
	printf("%s",s[m1]);
	if(j==0)
	printf("o'clock");
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章