UVa OJ 10035 Primary Arithmetic

UVa OJ 10035 

Problem B: Primary Arithmetic

Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty.

Input

Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

Output

For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

Sample Input

123 456
555 555
123 594
0 0

Sample Output

No carry operation.
3 carry operations.
1 carry operation.

計算兩個十進制整數在相加時需要多少次進位。每個輸入的整數不超過9個數字。


注意int的上限是2147483647,因此可以用整數來保存輸入,每次把a和b分別模10就能獲取它們的個位數。


#include <cstdio>
#include <cstdlib>
#include <cstring> 

using namespace std;

int main(int argc, char *argv[])
{
    int a, b;
    while (scanf("%d%d", &a, &b) == 2)
    {
        if (!a && !b)
            break;
        int c = 0, ans = 0;
        for (int i = 9; i >= 0; --i)
        {
            c = (a%10 + b%10 + c) > 9 ? 1 : 0;    // c是進位
            ans += c;
            a /= 10;
            b /= 10; 
        }
        if (ans == 0)
            printf("No carry operation.\n");
        else if (ans == 1)
            printf("%d carry operation.\n", ans);
        else
            printf("%d carry operations.\n", ans);
    } 
    //system("pause");
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章