杭電oj1092

Problem Description
Your task is to Calculate the sum of some integers.
 

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input
4 1 2 3 4 5 1 2 3 4 5 0
 

Sample Output
10 15
#include<iostream>
using namespace std;

int main()
{
	int i,n,sum=0;
	while(cin>>n)
	{	if(n!=0)
		{ 
			while(n--)
			{
				cin>>i;
				sum+=i;
			 } 
			cout<<sum<<endl;
			sum=0;
		} 
		else
			break;
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章