pojKMP專題:poj1961-Period poj2409-Power Strings poj2752-Seek the Name, Seek the Fame poj3461-Oulipo

pojKMP專題:poj1961-Period poj2409-Power Strings poj2752-Seek the Name, Seek the Fame poj3461-Oulipo

poj3461-Oulipo

Oulipo
Time Limit: 1000MS
Memory Limit: 65536K
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
Source
BAPC 2006 Qualification

問題是求匹配個數,裸的KMP。
關於一些KMP的說明:
考慮用p匹配T。
KMP的精髓在於前綴數組pre[]的意義:pre[i] = max{ j | j < i && p[1…j] < p[i-j+1…j] }
於是我們每次匹配失敗,只需要用pre[]跳轉,而無需直接返回模式串的第一個字符開始匹配。
pre[]的構建可以看成p和自己的匹配,注意是從p的第二個字符開始匹配,並且每次需要清空pre數組

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN =  1000000+5;

int pre[MAXN], n, m;
char p[MAXN], t[MAXN];

int KMP(){
    memset(pre, 0, sizeof pre);
    for (int i = 2, j = 0; i <= n ; ++i) {
      while (j && p[j+1] != p[i]) j = pre[j];
      if (p[j+1] == p[i]) ++j;
      pre[i] = j;
    }
    int ans = 0;
    for (int i = 1, j = 0; i <= m; ++i) {
      while (j && t[i] != p[j+1]) j = pre[j];
      if (t[i] == p[j+1]) ++j;
      if (j == n) ++ans;
    }
    return ans;
}

int main()
{
    freopen("in.txt", "r", stdin);
    int T;
    scanf("%d", &T);
    while (T--) {
      scanf("%s%s", &p[1], &t[1]);
      n = strlen(&p[1]), m = strlen(&t[1]);
      printf("%d\n", KMP());
    }
    return 0;
} 

poj2752-Seek the Name, Seek the Fame

Seek the Name, Seek the Fame
Time Limit: 2000MS
Memory Limit: 65536K
Description
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5
Source
POJ Monthly–20
06.01.22,Zeyuan Zhu

題意是求所有可能的前綴-後綴相同的字符串的長度。
由pre數組的意義,我們可以遞推地處理。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXN =  400000 + 5;

char s[MAXN];
int pre[MAXN];
vector<int> ans;

int main()
{
    freopen("in.txt", "r", stdin);
    while (scanf("%s", &s[1]) != EOF) {
      int n = strlen(&s[1]);
      memset(pre, 0, sizeof pre);
      for (int i = 2, j = 0; i <= n; ++i) {
        while (j && s[i] != s[j+1]) j = pre[j];
        if (s[i] == s[j+1]) ++j;  
        pre[i] = j;
      }
      int i = n;
      ans.clear();
      while (pre[i]) {
        ans.push_back(pre[i]);
        i = pre[i];  
      }
      ans.push_back(n);
      sort(ans.begin(), ans.end());
      for (vector<int>::iterator iter = ans.begin(); iter != ans.end(); ++iter)
        printf("%d ", *iter);
      printf("\n");
    }
    return 0;
}

poj1961-Period poj2409-Power Strings poj2752-Seek the Name, Seek the Fame
這兩道題差不多,題意是求重複週期地個數
可以用pre數組求出

poj1961

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXN =  1000000 + 10;

char s[MAXN];
int pre[MAXN];

int main()
{
    freopen("in.txt", "r", stdin);
    int cases = 0, n;
    while (scanf("%d", &n) && n) {
      ++cases;
      printf("Test case #%d\n", cases);
      scanf("%s", &s[1]);
      memset(pre, 0, sizeof pre);
      for (int i = 2, j = 0; i <= n; ++i) {
        while (j && s[i] != s[j+1]) j = pre[j];
        if (s[i] == s[j+1]) ++j;
        pre[i] = j;   
      } 
      for (int i = 2; i <= n; ++i)
        if (i % (i - pre[i]) == 0 && i / (i-pre[i]) != 1) 
          printf("%d %d\n", i, i / (i - pre[i]));
      printf("\n");
    }
    return 0;
}
poj2409

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 1000000+5;

char s[MAXN];
int pre[MAXN];

int main()
{
    freopen("in.txt", "r", stdin);
    while (scanf("%s", &s[1]) && s[1] != '.') {
      memset(pre, 0, sizeof pre);
      int n = strlen(&s[1]);
      for (int i = 2, j = 0; i <= n; ++i) {
        while (j && s[i] != s[j+1]) j = pre[j];
        if (s[i] == s[j+1]) ++j;
        pre[i] = j;   
      }
      int tep = n - pre[n], ans = 1;
      if (n % tep == 0) {
        ans = n / tep;
      } 
      printf("%d\n", ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章