A1009 Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

#include <stdio.h>
#define N 2001

struct Poly{
    int e;
    float c;
}poly[1001];
int main(){
    int k;
    scanf("%d", &k);
    for (int i = 0; i < k; i++){
        scanf("%d %f", &poly[i].e, &poly[i].c);
    }
    int k1;
    scanf("%d", &k1);
    int e;
    float c;
    float ans[N] = { 0 };
    for (int i = 0; i < k1; i++){
        scanf("%d %f", &e, &c);
        for (int j = 0; j < k; j++){
            ans[e + poly[j].e] += c * poly[j].c;
        }
    }
    int cnt = 0;
    for (int i = 0; i < N; i++){
        if (ans[i] != 0){
            cnt++;
        }
    }
    printf("%d", cnt);
    for (int i = N-1; i >= 0; i--){
        if (ans[i] != 0){
            printf(" %d %.1f", i, ans[i]);
        }
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章