HDU 1010(DFS,奇偶剪枝)

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

題意:

問狗能不能在T時間那一時刻恰好到達D點。

思路:

因爲問時刻,而非在時間段內,所以不能用BFS求最短路徑。暴力搜索全部路徑DFS,找到在T時刻能到達的所有點,看看是不是D點。需要剪枝不然會TLE。採用的剪枝方法是 奇偶剪枝法(鏈接傳送門)

這裏簡單說下,就是到達某一點後判斷該點到終點D的需要的最少時間(abs(x-ex)+abs(y-ey))和還剩的時間(T-s)的差是不是偶數。是奇數說明不可這條路是不可能的直接跳過。

AC代碼:


#include <cstdio>
#include <queue>
#include <cstring>
#include <cmath>
using namespace std ;
int dxy[4][2] = {1,0,0,1,0,-1,-1,0};
char cs[10][10];
int val[10][10];
int n,m,T,flag;
int ex,ey ;
bool check( int x,int y )
{
    if( x<0 || y<0 || x>=n || y>=m || val[x][y] || cs[x][y]=='X' )
    return false;
    return true;
}

void dfs( int x, int y ,int s )
{
    if( s==T && cs[x][y] == 'D')
    {
        flag = 1;
        return ;
    }
    int tt = T - s - ( abs(x-ex)+abs(y-ey) );   // 剪枝否則超時
    if( tt<0 || tt&1 )
    return ;

    int tx,ty;
    for( int i=0; i<4; i++ )
    {
        tx = x + dxy[i][0] ;
        ty = y + dxy[i][1] ;
        if( check(tx,ty) )
        {
            val[tx][ty] = 1;
            dfs(tx,ty,s+1);
            val[tx][ty] = 0 ;
        }
        if(flag) return ;
    }
}


int main( )
{
    int sx,sy;
    while( ~scanf("%d%d%d",&n,&m,&T) )
    {
        if( !n && !m && !T ) break;

        for( int i=0; i<n; i++ )
        {
            scanf("%s",cs[i]);
            for( int j=0; j<m; j++ )
            {
               if( cs[i][j]=='S' )
               {
                   sx=i,sy=j;
               }
               else if( cs[i][j]=='D' )
               {
                   ex=i,ey=j;
               }
            }
        }

        memset(val,0,sizeof(val));
        val[sx][sy] = 1;
        flag = 0;
        dfs(sx,sy,0);
        if(!flag) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章