杭電1328 IBM Minus One

IBM Minus One

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3653 Accepted Submission(s): 1912


Problem Description
You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story ends, in case you want to read the book for yourself :-)

After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.

Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

Input
The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

Output
For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time by the following letter in the alphabet, and replacing 'Z' by 'A'.

Print a blank line after each test case.

Sample Input
2
HAL
SWERC

Sample Output
String #1 IBM String #2 TXFSD
代碼:
#include<stdio.h>
#include<string.h>
int main()
{
	char sz[100];
	int c,n;
	scanf("%d\n",&n);
	for(int j=1;j<=n;j++)
	{	
		//scanf("%s",sz);
		gets(sz);
		c=strlen(sz);
		printf("String #%d\n",j);
		for(int i=0;i<c;i++)
		{
			if(sz[i]=='Z')
				sz[i]=sz[i]-25;
			else
				sz[i]=sz[i]+1;
			printf("%c",sz[i]);
		}
		printf("\n\n");//最後一行也要空行
	}
	return 0;
}

題意:將輸入的每個字母按照字母表+1,如果是Z,就跳回A。因此思路只要按照ACSII碼的轉換方法就ok了。

感想:這道題其實思路很簡單,就是那些格式把我弄暈了,要注意的幾點在代碼中用紅色標記,另外這道題還有一個最大的問題就是隻能用c++語言才能編譯通過。


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章