acm.jlu.edu.cn-1317-Tree Recovery

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

                                    D
                                   / /
                                  /   /
                                 B     E
                                / /     /
                               /   /     / 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output Specification

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB






#include<iostream>
#include<cstring>
using namespace std;
char pre[27],in[27];
void recover(int pi,int pj,int ii,int ij)
{
	if(pi+1>=pj)
		return;
	int i=ii;
	while(in[i]!=pre[pi])
		i++;
	for(int j=pi;j<pj-1;j++)
		pre[j]=pre[j+1];
	pre[pj-1]=in[i];
	recover(pi,pi+(i-ii),ii,i);
	recover(pi+(i-ii),pj-1,i+1,ij);
}
void main()
{
	while(cin>>pre>>in)
	{
		int len=strlen(pre);
		recover(0,len,0,len);
		cout<<pre<<endl;
	}
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章