HDU6348 Buy and Resell(2018CCPC網絡賽,優先隊列,貪心)

Problem Description

The Power Cube is used as a stash of Exotic Power. There are n cities numbered 1,2,…,n where allowed to trade it. The trading price of the Power Cube in the i-th city is ai dollars per cube. Noswal is a foxy businessman and wants to quietly make a fortune by buying and reselling Power Cubes. To avoid being discovered by the police, Noswal will go to the i-th city and choose exactly one of the following three options on the i-th day:
\1. spend ai dollars to buy a Power Cube
\2. resell a Power Cube and get ai dollars if he has at least one Power Cube
\3. do nothing
Obviously, Noswal can own more than one Power Cubes at the same time. After going to the n cities, he will go back home and stay away from the cops. He wants to know the maximum profit he can earn. In the meanwhile, to lower the risks, he wants to minimize the times of trading (include buy and sell) to get the maximum profit. Noswal is a foxy and successful businessman so you can assume that he has infinity money at the beginning.

Input

There are multiple test cases. The first line of input contains a positive integer T (T≤250), indicating the number of test cases. For each test case:
The first line has an integer n. (1≤n≤105)
The second line has n integers a1,a2,…,an where ai means the trading price (buy or sell) of the Power Cube in the i-th city. (1≤ai≤109)
It is guaranteed that the sum of all n is no more than 5×105.

Output

For each case, print one line with two integers —— the maximum profit and the minimum times of trading to get the maximum profit.

Sample Input

3
4
1 2 10 9
5
9 5 9 10 5
2
2 1 

Sample Output

16 4
5 2
0 0

Hint

In the first case, he will buy in 1, 2 and resell in 3, 4. profit = - 1 - 2 + 10 + 9 = 16
In the second case, he will buy in 2 and resell in 4. profit = - 5 + 10 = 5
In the third case, he will do nothing and earn nothing. profit = 0

思路

本題和cf的一道題基本一樣CodeForces 867E Buy Low Sell High(優先隊列,貪心)。有n個城市,你需要進行一種貨物交易,每個城市的價格不一樣,在每個城市只能進行一次交易,問你如何交易可以使得最後的利潤最大,求出最大值和最小的交易次數。

最大值的求法就是和cf那道題一樣,用一個從小到大的優先隊列維護,在每次進行交易的時候交易的次數就++,要使交易次數變少,那麼就使得中間的變化次數最大,標記一下每個物品買入的價格,出現過就減少次數,沒有就增加.

代碼

#include <bits/stdc++.h>
using namespace std;
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
const ll N = 1e5 + 40;
priority_queue<ll, vector<ll>, greater<ll>> q;
unordered_map<ll, ll> mp;
void solve()
{
    while (!q.empty())
        q.pop();
    mp.clear();
    ll n, x, ans = 0, cnt = 0;
    scanf("%lld", &n);
    for (ll i = 1; i <= n; i++)
    {
        scanf("%lld", &x);
        if (q.empty() || x <= q.top())
        {
            q.push(x);
        }
        else
        {
            ans += x - q.top();
            cnt++;
            if (mp[q.top()])
            {
                cnt--;
                mp[q.top()]--;
            }
            q.pop();
            q.push(x), q.push(x);
            mp[x]++;
        }
    }
    printf("%lld %lld\n", ans, cnt * 2);
}
int main()
{
    // freopen("in.txt", "r", stdin);
    ll t;
    scanf("%lld", &t);
    while (t--)
        solve();

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章