POJ-2758 checking the text(哈希+二分)

POJ-2758 checking the text(哈希+二分)

題目:
Wind’s birthday is approaching. In order to buy a really really fantastic gift for her, Jiajia has to take a boring yet money-making job - a text checker.

This job is very humdrum. Jiajia will be given a string of text what is English letters and he must count the maximum number of letters that can be matched, starting from two position of the current text simultanously. The matching proceeds from left to right, one character by one.

Even worse, sometimes the boss will insert some characters before, after or within the text. Jiajia wants to write a program to do his job automatically, this program should be fast enough, because there are only few days to Wind’s birthday.
Input
The first line of input file contains initial text.

The second line contains then number of commands n. And the following n lines describe each command. There are two formats of commands:

I ch p: Insert a character ch before the p-th. if p is larger than the current length of text, then insert at end of the text.

Q i j: Ask the length of matching started from the i-th and j-th character of the initial text, which doesn’t include the inserted characters.

You can assume that the length of initial text will not exceed 50000, the number of I command will not exceed 200, the number of Q command will not exceed 20000.
Output
Print one line for each Q command, contain the max length of matching.
Sample Input
abaab
5
Q 1 2
Q 1 3
I a 2
Q 1 2
Q 1 3
Sample Output
0
1
0
3

題意:
給你一個字符串,有兩種操作,一種是查詢兩個位置開始的最大公共子串,另一種是在原字符串第j個字符前加上一個字符。
插入<=200,查詢<=20000

計算字符串的hash值,對於每次查詢二分長度,插入時則把後面的hash值全重算一遍。

AC代碼:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
const long long LL=1000000009;
long long hsh[60005],pow[60005];
char s[60005];
int now[50005];
int len,m_len;
void get(int l,int len)
{
    for(int i=l;i<len;i++){
        if(i==0){hsh[i]=s[i];continue;}
        hsh[i]=hsh[i-1]*130+s[i];
        hsh[i]%=LL;
    }
}
void query(int x,int y)
{
    int l=1,r=min(len-x+1,len-y+1);
    while(l<r){
        int mid=(l+r)>>1;
        if((hsh[x+mid-1]-hsh[x-1]*pow[mid]%LL+LL)%LL==(hsh[y+mid-1]-hsh[y-1]*pow[mid]%LL+LL)%LL)
            l=mid+1;
        else r=mid;
    }
    printf("%d\n",l-1);
}
void change(char c,int x)
{
    if(x>len) x=len;
    memcpy(s+x+1,s+x,sizeof(char)*(len-x));
    s[x]=c;
    len++;
    get(x,len);

    for(int i=m_len-1;i>=0;i--){
        if(now[i]>=x) now[i]++;
        else break;
    }
}
int main()
{
    scanf("%s",s);
    len=strlen(s);
    m_len=len;
    int n;
    scanf("%d",&n);
    get(0,len);
    pow[0]=1;
    for(int i=1;i<len;i++){
        pow[i]=(pow[i-1]*130)%LL;
        now[i]=i;
    }
    char choice[5];
    int x,y;
    for(int i=0;i<n;i++){
        scanf("%s",choice);
        if(choice[0]=='Q') {
            scanf("%d %d",&x,&y);
            x--;
            y--;
            query(now[x],now[y]);
           // printf("%s\n",s);
        }
        else {
            scanf("%s %d",choice,&x);
            x--;
            change(choice[0],x);
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章