HDU Lowest Bit(Java版解題)

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3770 Accepted Submission(s): 2519
 

Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

 

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

 

Output

For each A in the input, output a line containing only its lowest bit.

 

Sample Input

26
88
0

 

Sample Output

2
8

 

 

import java.util.ArrayList;
import java.util.Scanner;

public class Main {

	public static void main(String args[])
    {
        Scanner cin = new Scanner(System.in);
        while(cin.hasNext()){
            int m = cin.nextInt();
            if(m==0) break;
            System.out.println(Integer.lowestOneBit(m));
        }
        
    }


}

解題的時候需要注意,這裏有個坑,輸入輸出事例那裏題目描述不太準確,應該是輸入一個數字然後再輸出個數字

輸入0結束程序運行,大家注意下吧

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章