HDU 1711 KMP模板

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13066 Accepted Submission(s): 5907

Problem Description

Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cassert>
using namespace std ;

const int N = 1e6 + 11 ;
const int M = 1e4 + 11 ;

int arr[N] , pattern[M] ;
int pre[M] ;
int n , m ;

void init() {
    for(int i = 0 ; i < n ; ++i) {
        scanf("%d" , &arr[i]) ;
    }
    for(int i = 0 ; i < m ; ++i) {
        scanf("%d" , &pattern[i]) ;
    }
}

void getpre() {
    int i = 0 , j = -1 ;
    pre[0] = -1 ;
    while(i < m-1) {
        if(j == -1 || pattern[i] == pattern[j]) {
            ++i , ++j ;
            if(pattern[i] != pattern[j]) pre[i] = j ;
            else pre[i] = pre[j] ;
        }else j = pre[j] ;
    }
}

void kmp() {
    int i = 0 , j = 0 ;
    while(i < n && j < m) {
        if(j == -1 || arr[i] == pattern[j]) {
            ++i , ++j ;
        }else j = pre[j] ;
    }
    if(j >= m) {
        printf("%d\n" , i-m+1) ;
    }else printf("-1\n") ;
}

int main() {
    //freopen("data.in" , "r" , stdin) ;
    int t ;
    scanf("%d" , &t) ;
    while(t--) {
        scanf("%d%d" ,&n ,&m) ;
        init() ;
        getpre() ;
        kmp() ;
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章