配置路由重分發實例

R1和R2的互聯地址爲10.0.0.0/30,R1和R3的互聯地址爲10.0.0.4/30,R3和R4的互聯地址爲10.0.0.8/30,R2和R5的互聯地址爲192.168.100.0/24,R1和ISP的互聯地址爲172.16.31.0/30。
路由器的Loopback0地址分別如下:R1爲1.1.1.1/32,R2爲2.2.2.2/32,R3爲3.3.3.3/32,R爲4.4.4.4/32,並使用此地址作爲OSPF協議RouterID。

wKiom1faRVqgK4G4AAFDU4gyYzo477.jpg-wh_50

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 10.0.0.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 10.0.0.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 2/0
R1(config-if)#ip address 172.16.31.1 255.255.255.252
R1(config-if)#no shutdown  
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 10.0.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)#ip add
R2(config-if)#ip address 192.168.100.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shutdown
R2(config-if)#exit


R3(config)#interface fastEthernet 1/0
R3(config-if)#ip address 10.0.0.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 10.0.0.9 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#no shutdown
R3(config-if)#exit


R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 10.0.0.10 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 1
R4(config-if)#ip address 192.168.3.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#no shutdown
R4(config-if)#exit

R5(config)#interface fastEthernet 0/0
R5(config-if)#ip address 192.168.100.2 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit
R5(config)#interface loopback 0
R5(config-if)#ip address 192.168.2.1 255.255.255.0
R5(config-if)#no shutdown
R5(config-if)#exit

ISP(config)#interface fastEthernet 0/0
ISP(config-if)#ip address 172.16.31.2 255.255.255.252
ISP(config-if)#no shutdown
ISP(config-if)#exit
ISP(config)#interface loopback 0
ISP(config-if)#ip address 59.56.61.1 255.255.255.0
ISP(config-if)#no shutdown
ISP(config-if)#exit

R1(config)#ip route 0.0.0.0 0.0.0.0 172.16.31.2
ISP(config)#ip route 0.0.0.0 0.0.0.0 172.16.31.1

R1(config)#router  ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 1.1.1.0 0.0.0.0 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#network 10.0.0.0 0.0.0.3 area 0
R1(config-router)#network 10.0.0.4 0.0.0.3 area 1

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 2.2.2.0 0.0.0.0 area 0
R2(config-router)#network 10.0.0.0 0.0.0.3 area 0
R2(config-router)#exit
R2(config)#router rip
R2(config-router)#network 192.168.100.0
R2(config-router)#exit
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 3.3.3.0 0.0.0.0 area 1
R3(config-router)#network 10.0.0.4 0.0.0.3 area 1
R3(config-router)#exit

R3(config)#ip route 192.168.3.0 255.255.255.0 10.0.0.10
R4(config)#ip route 10.0.0.0 255.255.255.252 10.0.0.9

R5(config)#router rip
R5(config-router)#network 192.168.2.0
R5(config-router)#network 192.168.100.0
R5(config-router)#exit


R1(config)#router ospf 1
R1(config-router)#default-information originate
R1(config-router)#exit

R2(config)#router ospf 1
R2(config-router)#redistribute rip subnets
R2(config)#router rip
R2(config-router)#redistribute ospf 1 metric 10
R2(config-router)#exit

R3(config)#router ospf 1
R3(config-router)#redistribute connected subnets
R3(config-router)#redistribute static subnets
R3(config-router)#exit

R1#show ip route
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 10.0.0.6, 00:01:45, FastEthernet1/0
     172.16.0.0/30 is subnetted, 1 subnets
C       172.16.31.0 is directly connected, FastEthernet2/0
     10.0.0.0/30 is subnetted, 3 subnets
O E2    10.0.0.8 [110/20] via 10.0.0.6, 00:01:45, FastEthernet1/0
C       10.0.0.0 is directly connected, FastEthernet0/0
C       10.0.0.4 is directly connected, FastEthernet1/0
C    192.168.1.0/24 is directly connected, Loopback1
O E2 192.168.2.0/24 [110/20] via 10.0.0.2, 00:01:53, FastEthernet0/0
O E2 192.168.100.0/24 [110/20] via 10.0.0.2, 00:01:53, FastEthernet0/0
O E2 192.168.3.0/24 [110/20] via 10.0.0.6, 00:02:12, FastEthernet1/0
S*   0.0.0.0/0 [1/0] via 172.16.31.2

R2(config)#do show ip route
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 10.0.0.1, 00:01:49, FastEthernet0/0
     10.0.0.0/30 is subnetted, 3 subnets
O E2    10.0.0.8 [110/20] via 10.0.0.1, 00:01:49, FastEthernet0/0
C       10.0.0.0 is directly connected, FastEthernet0/0
O IA    10.0.0.4 [110/2] via 10.0.0.1, 00:03:42, FastEthernet0/0
     192.168.1.0/32 is subnetted, 1 subnets
O       192.168.1.1 [110/2] via 10.0.0.1, 00:03:44, FastEthernet0/0
R    192.168.2.0/24 [120/1] via 192.168.100.2, 00:00:14, FastEthernet1/0
C    192.168.100.0/24 is directly connected, FastEthernet1/0
O E2 192.168.3.0/24 [110/20] via 10.0.0.1, 00:01:41, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 10.0.0.1, 00:02:30, FastEthernet0/0

R3#show ip route
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     10.0.0.0/30 is subnetted, 3 subnets
C       10.0.0.8 is directly connected, FastEthernet0/0
O IA    10.0.0.0 [110/2] via 10.0.0.5, 00:02:03, FastEthernet1/0
C       10.0.0.4 is directly connected, FastEthernet1/0
     192.168.1.0/32 is subnetted, 1 subnets
O IA    192.168.1.1 [110/2] via 10.0.0.5, 00:02:03, FastEthernet1/0
O E2 192.168.2.0/24 [110/20] via 10.0.0.5, 00:02:03, FastEthernet1/0
O E2 192.168.100.0/24 [110/20] via 10.0.0.5, 00:02:05, FastEthernet1/0
S    192.168.3.0/24 [1/0] via 10.0.0.10
O*E2 0.0.0.0/0 [110/1] via 10.0.0.5, 00:02:05, FastEthernet1/0

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章