SoO of EIGRP

image

使用SoO可以很好的避免主鏈路MPLS ***+備份鏈路產生的環路

R1:

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip vrf sitemap soo
ip address 14.14.14.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
network 14.14.14.1 0.0.0.0
no auto-summary
!
route-map soo permit 10
set extcommunity soo 1:1

 

R2:

ip vrf A
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding A
 ip vrf sitemap soo
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 23.23.23.2 0.0.0.0
no auto-summary
!
address-family ipv4 vrf A
  redistribute bgp 1 metric 10000 1 255 1 1500
  network 12.12.12.2 0.0.0.0
  no auto-summary
  autonomous-system 1
exit-address-family
!
router bgp 1
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
address-family ***v4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf A
  redistribute eigrp 1
  no synchronization
exit-address-family
!
route-map soo permit 10
set extcommunity soo 1:1
!
mpls ldp router-id Loopback0 force

 

R3:

ip vrf A
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip vrf forwarding A
 ip vrf sitemap soo
ip address 34.34.34.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
no auto-summary
!
address-family ipv4 vrf A
  redistribute bgp 1 metric 10000 1 255 1 1500
  network 34.34.34.3 0.0.0.0
  no auto-summary
  autonomous-system 1
exit-address-family
!
router bgp 1
no synchronization
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family ***v4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf A
  redistribute eigrp 1
  no synchronization
exit-address-family
!
route-map soo permit 10
set extcommunity soo 1:2
!
mpls ldp router-id Loopback0 force

 

R4:

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 34.34.34.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip vrf sitemap soo
ip address 14.14.14.4 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 4.4.4.4 0.0.0.0
network 14.14.14.4 0.0.0.0
network 34.34.34.4 0.0.0.0
no auto-summary
!
route-map soo permit 10
set extcommunity soo 1:2

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章