IPv6 Provider Edge

image

CE客戶爲IPv6路由,ISP內部使用IPv4地址,通過MP-BGP跨越骨幹網穿越IPv6前綴.

 

CE1:

interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 12::1/64
ipv6 rip cisco enable
!
ipv6 router rip cisco

 

CE2:

interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 45::5/64
ipv6 rip cisco enable
!
ipv6 router rip cisco

 

PE1:

interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip router isis
ipv6 address 2::2/128
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
ipv6 address 12::2/64
ipv6 rip cisco enable
ipv6 rip cisco default-information originate //下放一條默認路由給CE
!
interface FastEthernet1/1
ip address 23.23.23.2 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
router isis
net 49.0001.2222.2222.2222.00
!
router bgp 1
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 1
neighbor 4.4.4.4 update-source Loopback0
!
address-family ipv4
  neighbor 4.4.4.4 activate
exit-address-family
!
address-family ipv6
  redistribute rip cisco include-connected
  neighbor 4.4.4.4 activate //激活IPv6對等體
  neighbor 4.4.4.4 send-label //讓MPLS能夠爲IPv6前綴分發標籤
exit-address-family
!   

 

P:

interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip router isis
!
interface FastEthernet1/0
ip address 23.23.23.3 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
ip address 34.34.34.3 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
router isis
net 49.0001.3333.3333.3333.00

 

PE2:

interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip router isis
ipv6 address 4::4/128
!
interface FastEthernet1/0
ip address 34.34.34.4 255.255.255.0
ip router isis
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
ipv6 address 45::4/64
ipv6 rip cisco enable
ipv6 rip cisco default-information originate //下放一條默認路由給CE
!
router isis
net 49.0001.4444.4444.4444.00
!
router bgp 1
bgp router-id 4.4.4.4
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
!
address-family ipv4
  neighbor 2.2.2.2 activate
exit-address-family
!
address-family ipv6
  redistribute rip cisco include-connected
  neighbor 2.2.2.2 activate //激活IPv6對等體
  neighbor 2.2.2.2 send-label //讓MPLS能夠爲IPv6前綴分發標籤
exit-address-family
!

 

能夠收到PE2發過來的前綴45::/64

image

MPLS爲IPv6前綴分發標籤,使用::FFFF+32位IPv4地址填充下一跳

image

 

image

image

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章