ASA動態NAT轉換演示




務 實驗需求:
1.配置路由器和ASA的接口,實現網絡互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT轉換表

實驗拓撲:







驟 配置思路:
1.配置ASA防火牆對應端口的IP並設置端口名與優先級

  1. 配置R1 RR 各對應端口的IP地址關閉路由關閉,並驗證網絡是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置遠程
    實驗步驟:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (遠程密碼)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名內部)
    security-level 100 (優先級最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(優先級最低)

no shutdown
ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要進行地址轉換的網段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定義全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立轉換對應關係)
nat (inside,outside) dynamic in-out
q

R1:
enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (關閉路由功能)
ip default-gateway 10.1.1.254(設置網關)
end
ping 10.1.1.254 (驗證到網關是否互通)
設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:
enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (驗證到網關是否互通)

設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end




務 實驗需求:
1.配置路由器和ASA的接口,實現網絡互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT轉換表

實驗拓撲:







驟 配置思路:
1.配置ASA防火牆對應端口的IP並設置端口名與優先級

  1. 配置R1 RR 各對應端口的IP地址關閉路由關閉,並驗證網絡是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置遠程
    實驗步驟:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (遠程密碼)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名內部)
    security-level 100 (優先級最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(優先級最低)

no shutdown
ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要進行地址轉換的網段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定義全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立轉換對應關係)
nat (inside,outside) dynamic in-out
q

R1:
enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (關閉路由功能)
ip default-gateway 10.1.1.254(設置網關)
end
ping 10.1.1.254 (驗證到網關是否互通)
設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:
enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (驗證到網關是否互通)

設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end




務 實驗需求:
1.配置路由器和ASA的接口,實現網絡互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT轉換表

實驗拓撲:







驟 配置思路:
1.配置ASA防火牆對應端口的IP並設置端口名與優先級

  1. 配置R1 RR 各對應端口的IP地址關閉路由關閉,並驗證網絡是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置遠程
    實驗步驟:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (遠程密碼)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名內部)
    security-level 100 (優先級最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(優先級最低)

no shutdown
ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要進行地址轉換的網段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定義全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立轉換對應關係)
nat (inside,outside) dynamic in-out
q

R1:
enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (關閉路由功能)
ip default-gateway 10.1.1.254(設置網關)
end
ping 10.1.1.254 (驗證到網關是否互通)
設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:
enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (驗證到網關是否互通)

設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end




務 實驗需求:
1.配置路由器和ASA的接口,實現網絡互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT轉換表

實驗拓撲:







驟 配置思路:
1.配置ASA防火牆對應端口的IP並設置端口名與優先級

  1. 配置R1 RR 各對應端口的IP地址關閉路由關閉,並驗證網絡是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置遠程
    實驗步驟:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (遠程密碼)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名內部)
    security-level 100 (優先級最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(優先級最低)

no shutdown
ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要進行地址轉換的網段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定義全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立轉換對應關係)
nat (inside,outside) dynamic in-out
q

R1:
enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (關閉路由功能)
ip default-gateway 10.1.1.254(設置網關)
end
ping 10.1.1.254 (驗證到網關是否互通)
設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:
enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (驗證到網關是否互通)

設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end




務 實驗需求:
1.配置路由器和ASA的接口,實現網絡互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT轉換表

實驗拓撲:







驟 配置思路:
1.配置ASA防火牆對應端口的IP並設置端口名與優先級

  1. 配置R1 RR 各對應端口的IP地址關閉路由關閉,並驗證網絡是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置遠程
    實驗步驟:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (遠程密碼)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名內部)
    security-level 100 (優先級最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(優先級最低)

no shutdown
ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要進行地址轉換的網段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定義全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立轉換對應關係)
nat (inside,outside) dynamic in-out
q

R1:
enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (關閉路由功能)
ip default-gateway 10.1.1.254(設置網關)
end
ping 10.1.1.254 (驗證到網關是否互通)
設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:
enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (驗證到網關是否互通)

設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end




務 實驗需求:
1.配置路由器和ASA的接口,實現網絡互通
2.配置路由
R1可以Telnet到RR,RR不可以Telnet到R1,
3.使用命令show xlate 查看NAT轉換表

實驗拓撲:







驟 配置思路:
1.配置ASA防火牆對應端口的IP並設置端口名與優先級

  1. 配置R1 RR 各對應端口的IP地址關閉路由關閉,並驗證網絡是否互通
  2. 在ASA上配置NAT
    4.在R1 RR配置遠程
    實驗步驟:
    ASA:
    enable
    tedu.cn
    configuration terminal
    hostname ASA
    enable password 123
    passwd 123 (遠程密碼)
    clear configure all
    interface gigabitEthernet 0
    nameif inside (端口名內部)
    security-level 100 (優先級最高)
    no shutdown
    ip address 10.1.1.254 255.255.255.0
    exit
    interface gigabitEthernet 1
    nameif outside(端口名外部)
    security-level 0(優先級最低)

no shutdown
ip address 172.16.1.254 255.255.255.0
exit
object network inside (指定需要進行地址轉換的網段)
subnet 10.1.1.0 255.255.255.0
exit
object network in-out (定義全局地址池)
rang 172.16.1.100 172.16.1.200
exit
object network inside (建立轉換對應關係)
nat (inside,outside) dynamic in-out
q

R1:
enable
configuration terminal
hostname R1
interface fastEthernet 0/0
no shutdown
ip address 10.1.1.1 255.255.255.0
exit
no ip routing (關閉路由功能)
ip default-gateway 10.1.1.254(設置網關)
end
ping 10.1.1.254 (驗證到網關是否互通)
設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end

RR:
enable
configuration terminal
hostname RR
no ip routing
interface fastEthernet 1/0
no shutdown
ip address 172.16.1.1 255.255.255.0
end
ping 172.16.1.254 (驗證到網關是否互通)

設置遠程
enable
configuration terminal
enable password 123
line vty 0
password 123
end





在R1上遠程RR

在RR上遠程R1

在ASA輸入show xlate 查看NAT轉化表

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章