hdu dfs

Problem C

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 41   Accepted Submission(s) : 25

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

 

Input

First line contains two integers stand for N and M. Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. Process to the end of the file.

 

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

 

 

Sample Input


 

7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

 

 

Sample Output


 

13

 

可以用dfs做也可以用bfs,只是我bfs 還不熟練,以後補上bfs代碼 

#include<stdio.h>
#include<string.h>
int vis[1010][1010];
char a[1010][1010];
int m,n,t,ans,step,k,s;
void dfs(int x,int y,int step)
{
    if(vis[x][y]||a[x][y]=='#'||step>=ans) return ;
    if(a[x][y]=='r')
    {
        k=1;
        if(step<ans) ans=step;
        return ;
    }

    if(a[x][y]=='x')
    {
        step++;
    }
    vis[x][y]=1;
    dfs(x+1,y,step+1);
    dfs(x-1,y,step+1);
    dfs(x,y+1,step+1);
    dfs(x,y-1,step+1);
    vis[x][y]=0;

}
int main()
{
    int i,j,ax,ay;
    while(~scanf("%d%d",&m,&n))
    {
        memset(vis,0,sizeof(vis));
        memset(a,'#',sizeof(a));
        for(i=0; i<m; i++)
        {
            for(j=0; j<n; j++)
            {
                scanf(" %c",&a[i][j]);
                if(a[i][j]=='a')
                {
                    ax=i;
                    ay=j;
                }
            }
        }
        ans=100000;
        k=0;
        dfs(ax,ay,0);
        if(k) printf("%d\n",ans);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");

        }
        return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章