PAT (Advanced Level) Practice 1001 A+B Format(20 分)C語言

1001 A+B Format(20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 C

#include<stdio.h>
int main() {
	int a,b,sum,m;
	scanf("%d %d",&a,&b);
	sum=a+b;
	if(sum<0)
		m=-sum;
	else
		m=sum;
	if(m>=1000||m<=-1000) {
		if(m>=1000000||m<=-1000000) {
			printf("%d",sum/1000000);
			printf(",");
			if((m/1000)%1000>=100)
				printf("%d",(m/1000)%1000);
			else if((m/1000)%1000>=10)
				printf("0%d",(m/1000)%1000);
			else if((m/1000)%1000>=0)
				printf("00%d",(m/1000)%1000);
			printf(",");
		} else {
			printf("%d",sum/1000);
			printf(",");
		}
		if(m%1000>=100)
			printf("%d",m%1000);
		else if(m%1000>=10)
			printf("0%d",m%1000);
		else if(m%1000>=0)
			printf("00%d",m%1000);
	} else {
		printf("%d",sum);
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章