HDU 1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 432656    Accepted Submission(s): 84239

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1: 1 + 2 = 3

Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

解題思路:

在題目給的樣例數據過了之後,再試試‘00008+2’有無前導0,在注意題目的輸出格式。

代碼如下:

#include<stdio.h>
#include<string.h>
#include<math.h>
char a[1005],b[1005],c[1010];
void sum()
{
    int aa[1005]={0},bb[1005]={0},cc[1005]={0},j=0;
    int len1=strlen(a),i,k=0;
    int len2=strlen(b);
    int len3=len1>len2?len1:len2;
    for(i=len1-1,j=0;i>=0;i--,j++) aa[j]=a[i]-'0';
    for(i=len2-1,j=0;i>=0;i--,j++) bb[j]=b[i]-'0';
    for(i=0;i<len3;i++) cc[i]=aa[i]+bb[i];
    for(i=0;i<len3;i++)
    {
        if(cc[i]>=10)
        {
            cc[i]-=10;
            cc[i+1]++;
            if(k==len3-1)
                len3++;
        }
        k++;
    }
    for(i=1004;i>0;i--)                 //刪除前導0
    {
        if(cc[i]==0)
            continue;
        else
            break;
    }
    for(;i>=0;i--)
        printf("%d",cc[i]);
    printf("\n");
}
int main()
{
    int N,i=1,n;
    scanf("%d",&N);
    n=N;
    while(N--)
    {
        scanf("%s%s",a,b);
        printf("Case %d:\n",i);
        printf("%s + %s = ",a,b);
        sum();
        if(i<n)
            printf("\n");
        i++;
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章