HDU 1671 Phone List(字典樹)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25986    Accepted Submission(s): 8682

 

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2

3

911

97625999

91125426

5

113

12340

123440

12345

98346

Sample Output

NO

YES

題目意思:輸入若干組號碼,判斷任意一組號碼是否是其它號碼的前綴,如果存在一個號碼是其它一個號碼的前綴就輸出"NO",如果不存在就輸出"YES"。

題目做法:使用字典樹將字符串存入,存入成功values++,在存入字符串時判斷values值是否爲0,不爲0代表已經存在當前字符串的前綴,輸出"NO",需要注意的是,當字符串長的在前,短的在後時,當短的字符串存入時,還要判斷之後的孩子節點是否爲NULL,不爲空代表當前字符串爲存入過的字符串的前綴,輸出"NO"。

代碼

#include<iostream>
#include<string>
#include<string.h>
#include<stdlib.h>
#include<stdio.h>
#include<sstream>
using namespace std;
struct Trie
{
    int values;
    Trie *child[10];
    Trie()
    {
        values=0;
        memset(child,NULL,sizeof(child));
    }
}*root;
bool f;
int ans=0;
void create(string s)                       //創建字典樹並判斷
{
    Trie *x=root;
    for(int i=0; i<s.length();i++)
    {
        int d=s[i]-'0';
        if(x->child[d]==NULL)
        {
            x->child[d]=new Trie;
        }
        x=x->child[d];
        if(x->values!=0)           //代表存在當前字符串的前綴
        {
            f=false;
            break;
        }
    }
    x->values++;
    for(int i=0;i<10;i++)         //判斷之前存在包括它的字符串
    {
        if(x->child[i]!=NULL)
        {
            f=false;
            return;
        }
    }
}
void deleteTrie(Trie *x)            //清空內存
{
    if(x==NULL)
        return;
    for(int i=0; i<10; i++)
    {
        if(x->child[i]!=NULL)
        {
            deleteTrie(x->child[i]);
        }
    }
    delete x;
}
int main()
{
    int T,n,f1,k;
    string s;
    cin>>T;
    while(T--)
    {
        cin>>n;
        root=new Trie;
        f=true;
        k=n;
        while(n--)
        {
            cin>>s;
            create(s);
        }
        if(f==false)
        {
            cout<<"NO\n";
        }
        if(f==true)
            cout<<"YES\n";
        deleteTrie(root);
    }
}

  

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章