HDU1013 Digital Roots(數根公式)

題目:HDU1013

 

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 93380    Accepted Submission(s): 29125

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24 39 0

Sample Output

6 3

 

方法一:

以字符串形式輸入一個數。將其每一位轉變成整數加到一個新數上,然後新數的各個位不斷相加,直至變爲小於10的正整數。

代碼:

#include <iostream>
#include <string>
using namespace std;

int main()
{
	string num;
	int Intnum, single;
	while (cin >> num)
	{
		if (num[0] == '0')
			break;
		Intnum = 0;
		single = 0;
		int length = num.size();
		for (int i = 0; i < length; i++)
			Intnum += num[i] - '0';
			
		while (Intnum > 0)
		{
			single += Intnum % 10;
			Intnum /= 10;
			if (Intnum == 0 && single >= 10)
			{
				Intnum = single;
				single = 0;
			}
		}
		cout << single << endl;
	}
	
	return 0;
}

 

方法二:(記住結論)

利用數論中的數根結論,Digital Roots(數根) = (sum - 1) % 9 + 1.   (數根公式推導)

其實這個式子的真正意義就是對9取餘,只不過是如果9對9取餘,正常結果應該是0,但是這裏要輸出的是9,所以用那個式子來寫就免得專門判斷是不是0了。

代碼:

#include <iostream>
#include <string>
using namespace std;
 
 
int main()
{
    string num;
    while(cin >> num)
    {
        if(num[0]=='0')
            break;
        int sum = 0;
        for (int i = 0; i < num.size(); i++)
           sum += num[i] - '0';

        cout << (sum - 1) % 9 + 1 << endl;
    }
    
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章