農夫約翰的牛

Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input
A single line with a single integer, N.

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input
7

Sample Output
6

譯:

問題描述

農夫約翰命令他的牛尋找不同的數字集合,這些數字和一個給定的數字。奶牛隻使用整數冪爲2的數字。下面是可能的數字集合,它們的和是7:

1)1 + 1 + 1 + 1 + 1 + 1 + 1

2)1 + 1 + 1 + 1 + 1 + 2

3)1 + 1 + 1 + 2 + 2

4)1 + 1 + 1 + 4

5)1 + 2 + 2 + 2

6)1 + 2 + 4

幫助FJ計算一個給定整數N的所有可能表示形式(1 <= N <= 1,000,000)。

輸入

一行只有一個整數N。

輸出

表示N的方法的個數作爲表示的和。由於這個數字可能很大,所以只打印最後9位數字(以10爲基數表示)。

樣例輸入

7

樣例輸出

6

#include<stdio.h>
int result[1000000];
int n;
int count = 0;
void search(int k,int sum) {
	for (int i = 1; i < n; i *= 2) {
		if (i >= result[k - 1]) {		//保證比前一個數大
			result[k] = i;
			if (sum + i >= n) {
				if (sum + i == n)
					count++;
			}
			else
				search(k + 1, sum + i);
		}
	}
}
int main() {
	scanf("%d", &n);
	search(1, 0);
	printf("%d", count);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章