POJ - 2109

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the n
th. power, for an integer k (this integer is what your program must find).

    Input
    
  
   The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10
   101 and there exists an integer k, 1<=k<=10
   9 such that k
   n = p. 
  

    Output
    
  
   For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p. 
  

    Sample Input
    2 16
    3 27
    7 4357186184021382204544

    Sample Output
    4
    3
    1234

查過網站的意思好像是說結果直接等於p的1/n次方;如16的1/2次方得4,27得1/3次方得3,等等等,而且這個運算過程可以用double來定義變量。

#include<cmath>
#include<iostream>
using namespace std;
int main()
{
        double n,p;
        while(cin>>n>>p)
        {
                cout<<pow(p,1/n)<<endl;
        }
        return 0;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章