杭電OJHDU1326 Box of Bricks

Problem Description

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. Look, I've built a wall!'', he tells his older sister Alice.Nah, you should make all stacks the same height. Then you would have a real wall.’’, she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

在這裏插入圖片描述

Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 <= n <= 50 and 1 <= hi <= 100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.’’, where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input

6
5 2 4 1 7 5
0

Sample Output

Set #1
The minimum number of moves is 5.
題目的意思是先給出幾棟高低不一的磚塊,每次只能移動一個磚塊,問要把它們移到一樣的高度,問要搬幾次。其實就是算要搬幾次而不用糾結它這個過程怎麼搬。
代碼如下:

#include<stdio.h>
int main()
{
    int n,sum=0,count=0;
    int a[100];
    int m=1;
    while(scanf("%d",&n)!=EOF&&(n!=0))
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum=sum+a[i];
        }
        int k=sum/n;
        for(int j=1;j<=n;j++)
        {
            if(a[j]>k)
            {
                count=count+(a[j]-k);
            }
        }
        printf("Set #%d\n",m);
        printf("The minimum number of moves is %d.\n\n",count);
        m++;
        sum=0;
        count=0;
        k=0;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章