杭電oj 1004------Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 153132    Accepted Submission(s): 60752


 

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

 

Sample Input


 

5 green red blue red red 3 pink orange pink 0

 

 

Sample Output


 

red pink

 

 

Author

WU, Jiazhi

 

 

Source

ZJCPC2004

 用二維數組存儲顏色

#include <stdio.h>
#include <string.h>
int main()
{
    int n,i,j,max,t,a[1100];
    char s[1100][20];
    while(~scanf("%d",&n),n)
    {
        max=0;
        t=0;
        memset(a,0,sizeof(a));      //初始化數組a
        for(i=0;i<n;i++)
        { 
            scanf("%s",s[i]);       //輸入顏色
        }
        getchar();                  //清除回車
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                if(strcmp(s[i],s[j])==0)    //逐次比較
                    a[i]++;                 //一樣a[i]++
            }                               //以樣例 5
            if(max<a[i])                    //       green
            {                               //       red
                max=a[i];                   //       blue
                t=i;      //最多次下標       //       red
            }                               //       red       這時候 a[0]~a[4]的數分別爲0 2 0 1 0 
                                            // 2的下標爲1  就是red出現最多次
        }
        printf("%s",s[t]);
        printf("\n");
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章