hdoj 1021------Fibonacci Again

 

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77019    Accepted Submission(s): 34854


 

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 

 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

 

 

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

 

 

Sample Input


 

0 1 2 3 4 5

 

 

Sample Output


 

no no yes no no no

 

 

Author

Leojay

F[n]能被3除盡輸出yes 否則輸出no

這個題可以正常寫也可以找規律

 

正常寫

#include <iostream>
#include <cstdio>
using namespace std;
int a[1000000];
int main()
{
    int n,i;
    while(~scanf("%d",&n))
    {
        a[0]=7;
        a[1]=11;
        for(i=2;i<=n;i++)
        {
            a[i]=(a[i-1]+a[i-2])%3;
        }
        if(a[n]==0)
        {
            printf("yes\n");
        }
        else
        {
            printf("no\n");
        }
    }
    return 0;
}

找規律 n爲 2,6,10,14...... 的時候輸出yes,每4個一循環,第二個輸出yes

#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n%4==2)
            printf("yes\n");
        else
            printf("no\n");
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章