hdoj 1019------Least Common Multiple

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 64937    Accepted Submission(s): 24772


 

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

 

 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

 

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

 

Sample Input


 

2 3 5 7 15 6 4 10296 936 1287 792 1

 

 

Sample Output


 

105 10296

 

 

Source

East Central North America 2003, Practice

求最小公倍數 輾轉相除法

#include <iostream>
#include <cstdio>
using namespace std;

int zhanzhuan(int a,int b)      //求最小公倍數函數 用輾轉相除法
{
    int x,y,t;
    x=a;
    y=b;
    while(b!=0)
    {
        t=b;
        b=a%b;
        a=t;

    }
    return x*(y/a);               //注意先除後乘 否則超限出錯
}
int main()
{
    int n,i,j,m;
    int a,b;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        a=1;                        //a歸1
        scanf("%d",&m);
        for(j=0;j<m;j++)
        {
            scanf("%d",&b);         
            a=zhanzhuan(a,b);       //兩兩求最小公倍數 
        }
        printf("%d\n",a);
    }
    return 0;

}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章