1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

Solution Code:

#include <iostream>
#include <algorithm>
#include <map>
using namespace std;

typedef struct student
{
	int ID;
	int grade[4];
	int best_rank;
	int best_type;//0:c,1:m,2:e,3:a
}student;

bool cmpC(student a, student b)
{
	return a.grade[0] > b.grade[0];
}

bool cmpM(student a, student b)
{
	return a.grade[1] > b.grade[1];
}

bool cmpE(student a, student b)
{
	return a.grade[2] > b.grade[2];
}

bool cmpA(student a, student b)
{
	return a.grade[3] > b.grade[3];
}

/*******************************
根據分數確定名次,100 90 90 88對應的名次1 2 2 4
若當前記錄的分數與當前學生的分數相等,則學生名次爲當前記錄的名次,不做處理
若不相等,則當前名次應爲該學生對應的下標+1,同時修改當前記錄的分數
比較當前名次與學生最好名次
***********************************/
void getBestRank(student *stu, int size, int type)
{ 
	// sort by big to small
	if (type == 0) // sort by c 
		sort(stu, stu+size, cmpC);
	else if (type == 1) // sort by m 
		sort(stu, stu+size, cmpM);
	else if (type == 2) // sort by e
		sort(stu, stu+size, cmpE);
	else //sort by a
		sort(stu, stu+size, cmpA);
	
	int cur_grade = stu[0].grade[type];
	int cur_rank = 1;
	for (int i = 0; i < size; ++i){
		if (cur_grade != stu[i].grade[type]){//確定下一個名次的分數
			cur_grade = stu[i].grade[type];
			cur_rank = i + 1;
		}
		if (stu[i].best_rank > cur_rank){//記錄最好的名次
			stu[i].best_rank = cur_rank;
			stu[i].best_type = type;
		}
	}
}

int main()
{
	int n, m;
	cin >> n >> m;
	student *stu = new student[n];
	for (int i = 0; i < n; ++i) {
		cin >> stu[i].ID;
		stu[i].best_rank = 999999999;
		int sum = 0;
		for (int j = 0; j < 3; ++j){
			cin >> stu[i].grade[j];
			sum += stu[i].grade[j];
		} 
		stu[i].grade[3]	= sum / 3;
	}
	// A>C>M>E
	getBestRank(stu, n, 3);
	for (int i = 0; i < 3; ++i)
		getBestRank(stu, n, i);
	// 便於查找
	map<int, student> stu_index;
	for (int i = 0; i < n; ++i){
		stu_index.insert(pair<int, student>(stu[i].ID, stu[i]));
	}

	int ID;
	for (int i = 0; i < m; ++i){
		cin >> ID;
		if (stu_index.find(ID) == stu_index.end())
			cout << "N/A" << endl;
		else{
			cout << stu_index[ID].best_rank << " ";
			if (stu_index[ID].best_type == 0)
				cout << "C" << endl;
			else if (stu_index[ID].best_type == 1)
				cout << "M" << endl;
			else if (stu_index[ID].best_type == 2)
				cout << "E" << endl;
			else
				cout << "A" << endl;
		}
	}

	delete[] stu;
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章