1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

Solution Code:

/***********************
首先,判斷n是否是素數,如果是素數,則繼續執行,否則,輸出No
然後,判斷n在d進制下逆數是否是的素數(逆數指數字順序顛倒)
****************************/
#include <iostream>
#include <cmath>
using namespace std;

// 求得D進制下的逆數,並轉化爲十進制
int getRevNumber(int number, int raddix)
{
	int rev_result[1000];
	int result = 0;
	int index = 0;
	// 求得D進制下的逆數
	while(number != 0) {
		rev_result[index++] = number % raddix;
		number /= raddix;
	}
	// 轉化爲10進制數
	for (int i = 0; i < index; ++i){
		result = result*raddix + rev_result[i];
	}
	return result;
}

// 判斷是否爲素數
bool isPrime(int number)
{
	if (number <= 1)
		return false;
	if (number == 2 || number == 3)
		return true;
	else {
		int end = int(sqrt(number)) + 1;
		for (int i = 2; i < end; ++i) {
			if (number % i == 0)
				return false;
		}
		return true;
	}
}

int main()
{
	int n, d;
	while (cin >> n && n > 0) {
		cin >> d;
		if (!isPrime(n)) {
			cout << "No" << endl;
			continue;
		}
		if (isPrime(getRevNumber(n, d))) {
			cout << "Yes" << endl;
		}
		else
			cout << "No" << endl;
	}

	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章