POJ-3660-Cow Contest

給出牛之間的強弱關係,讓你確定有多少頭牛能夠確定其排名。

用Floyd做,對每給的一個勝負關係連一條邊,最後跑一次Floyd,然後判斷一頭牛所確定的關係是否是n-1次,若是,則這頭牛的排名可以確定

有n只奶牛,有n個連續的實力,如果u的實力大於v的實力,就能打贏它,
*        然後給定m種關係,求最後能確定其排名的奶牛個數。


N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn=102;
int map[102][102];
int n,m;
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(map,0,sizeof(map));
		for(int i=0;i<m;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			map[a][b]=1;
		}
		for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
		if(map[i][k]&&map[k][j])
		map[i][j]=1;
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			int res=n-1;
			for(int j=1;j<=n;j++)
			if(map[i][j]||map[j][i])
			res--;
			if(!res)
			ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章