POJ - 3259 Wormholes

題目大意:蟲洞問題,現在有n個點,m條邊,代表現在可以走的通路,比如從a到b和從b到a需要花費c時間,現在在地上出現了w個蟲洞,蟲洞的意義就是你從a到b話費的時間是-c(時間倒流,並且蟲洞是單向的),現在問你從某個點開始走,能回到從前

解題思路:其實給出了座標,這個時候就可以構成一張圖,然後將回到從前理解爲是否會出現負權環,用bellman-ford就可以解出了

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
#include<iostream>
#include<cstdio>
#include<cstring>
#define MAXV 25100
using namespace std;
struct edge{
    int from,to,cost;
    edge(){}
    edge(int from,int to,int cost)
    {
        this->from=from;
        this->to=to;
        this->cost=cost;
    }
};
edge es[MAXV];
int d[MAXV];
int V,E;
bool find_negative_loop()
{
    memset(d,0,sizeof(d));
    for(int i=0;i<V;++i)
    {
        for(int j=0;j<E;++j)
        {
            edge e=es[j];
            if(d[e.to]>d[e.from]+e.cost)
            {
                d[e.to]=d[e.from]+e.cost;
                if(i==V-1)
                    return true;
            }
        }
    }
    return false;
}
int main()
{
    int F,n,m,w;
    cin>>F;
    while(F--)
    {
        cin>>n>>m>>w;
        V=n;
        E=0;
        for(int i=0;i<m;++i)
        {
            int from,to,cost;
            cin>>from>>to>>cost;
            --from;
            --to;
            es[E].from=from;
            es[E].to=to;
            es[E].cost=cost;
            ++E;
            es[E].from=to;
            es[E].to=from;
            es[E].cost=cost;
            ++E;
        }
        for(int i=0;i<w;i++)
        {
            int from,to,cost;
            cin>>from>>to>>cost;
            --from;
            --to;
            es[E].from=from;
            es[E].to=to;
            es[E].cost=-cost;
            ++E;
        }
        if(find_negative_loop())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章