Easy Math

題目

Easy Math

Given nn integers a1,a2,…,ana1,a2,…,an, check if the sum of their square root a1−−√+a2−−√+⋯+an−−√a1+a2+⋯+an is a integer.

Input

The input consists of multiple tests. For each test:

The first line contains 11 integer nn (1≤n≤1051≤n≤105). The second line contains nn integers a1,a2,…,ana1,a2,…,an (0≤ai≤1090≤ai≤109).

Output

For each test, write "Yes" if the sum is a integer, or "No" otherwise.

Sample Input

    2
    1 4
    2
    2 3

Sample Output

    Yes
    No

題意:就是給你n個整數,求這n個數的平方根是否爲一個整數。算是一個水題吧。

AC代碼:

#include<stdio.h>
#include<math.h>
int a[150005];
int main()
{
    int n;
    while(scanf("%d",&n)>0)
    {
        int flag = 1;
        for(int i = 0; i < n ; i ++)
        {
            scanf("%d",&a[i]);
            int p=(int)sqrt( 1.0 * a[i] + 0.5) + 1;
            while(flag)
            {
                if((int) p * p == a[i])
                {
                    break;
                }
                if((int) p * p < a[i])
                {
                     flag = 0;
                }
                p--;
            }

        }
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章