How Many Tables(並差集)

How Many Tables

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

核心代碼爲:

	for(int i=1;i<=m;i++)
	{
		if(mark[pre[find(i)]]++==0)//判斷是否在一個集合中 不在一個集合中 那麼ans++; 
		ans++;
	}

這個是什麼意思來?
事先給mark[]數組賦初始值爲0,然後每一個人都要遍歷判斷一下自己所在的上級哪個沒有出現,那麼那個人就得自己一張桌子了。例如:
5 3
1 2
2 3
3 4
pre[1]=1; pre[2]=1; pre[3]=2; pre[4]=3;
mark[1]=2; mark[2]=1; mark[3]=1; mark[4]=0;mark[5]=0
所以要準備兩張桌子

#include <cstdio>
#include <iostream>
#include <cstring>
#define N 10000
int pre[N],mark[N];
using namespace std;

int find(int x)
{
	int r=x;
	while(pre[r]!=r)
	{
		r=pre[r];
	}
	
	int i=x,j;
	while(i!=r)
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}

void init()
{
	for(int i=1;i<=N;i++)
	{
	pre[i]=i;
	}
	memset(mark,0,sizeof(mark));
}

int main()
{
	int t,m,n,p1,p2;
	scanf("%d",&t);
	while(t--)
	{
	init();
	int ans=0;
	scanf("%d %d",&m,&n);
	while(n--)
	{
		scanf("%d %d",&p1,&p2);
		int fx=find(p1);
		int fy=find(p2);
		if(fx!=fy)
		pre[fx]=fy;	
	}	
	for(int i=1;i<=m;i++)
	{
		if(mark[pre[find(i)]]++==0)//判斷是否在一個集合中 不在一個集合中 那麼ans++; 
		ans++;
	}
	printf("%d\n",ans);
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章