Let the Balloon Rise

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

#include <algorithm>
#include <string.h>
#define N 1024
#define MAXN 0x3f3f3f3f
#include <iostream>
#include <map>
#include <string>
using namespace std;
int main()
{
	map <string, int> str_int;
	int n;
	string str;
	while (cin>> n && n > 0)
	{
		str_int.clear();
		while (n--)
		{
			cin >> str;
			str_int[str]++;
 
		}
		int max = 0;
		string max_color;
		map<string, int>::iterator it;
		for (it = str_int.begin(); it != str_int.end(); it++)
		{
			if (it->second > max)
			{
				max = (*it).second;
				max_color = (*it).first;
			}
		}
		cout << max_color << endl;
 
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章