POJ - 1523 SPF 【圖的割點】

                                            SPF

Time Limit: 1000MS   Memory Limit: 10000K

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

題意

給你一個圖,讓你求圖種的割點(刪去後破壞圖的連通性的點),以及去掉割點後原圖被分成幾個子圖

解題思路

先求割點,再用染色法求子圖數。

如何求割點 超易懂講解+模板:https://blog.csdn.net/weixin_42765557/article/details/87522469

ACCode

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;
vector<int > vec[1001];
bool flag[1001];
int num[1001],low[1001],root,index,n;
int _max(int x,int y,int z)
{
	return max(x,max(y,z));
}
void init()
{
	for(int i=1;i<=1000;i++) {
		vec[i].clear();
		num[i] = 0;
		low[i] = 0;
		flag[i] = false;
	}
	index = 0;
	root = 1;
	n = 0;
	return ;
}
void dfs(int cur,int f)
{
	int child=0;
	index++;
	num[cur] = index;
	low[cur] = index;
	int to;
	for(int i=0;i<vec[cur].size();i++) {
		to = vec[cur][i];
		if(num[to] == 0) {
			child++;
			dfs(to,cur);
			low[cur] = min(low[cur],low[to]);
			if(cur != root && low[to] >= num[cur]) flag[cur] = true;
			if(cur == root && child == 2) flag[cur] = true;
		}
		else if(to != f) {	//&&num[to] != 0
			low[cur] = min(low[cur],num[to]);
		}
	} 
	return ;
}
void dfs2(int u,int col)
{
	num[u] = col;
	for(int i=0;i<vec[u].size();i++) {
		int to = vec[u][i];
		if(num[to] == 0)
			dfs2(to,col);
	}
	
}
int main()
{	
	int u,v,Network=0;
	while(scanf("%d",&u) && u != 0) {
		scanf("%d",&v);
		init();
		n = _max(n,u,v);
		vec[u].push_back(v);
		vec[v].push_back(u);
		while(scanf("%d",&u) && u != 0) {
			scanf("%d",&v);
			n = _max(n,u,v);
			vec[u].push_back(v);
			vec[v].push_back(u);
		}
		dfs(1,0); 
		printf("Network #%d\n",++Network);
		bool flag2 = false;
		for(int i=1;i<=n;i++) {
			if(flag[i]) {
				flag2 = true ; //有割點 
				for(int j=1;j<=n;j++)
					num[j] = 0; //用作color
				num[i] = -1;
				int tot = 0; 
				for(int j=1;j<=n;j++) {
					if(num[j] == 0 && j != i) {
						tot++;
						dfs2(j,tot);
					}
				}
				printf("  SPF node %d leaves %d subnets\n",i,tot);
			}
		}		
		if(!flag2) printf("  No SPF nodes\n");
		printf("\n");
	} 
	
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章