PAT甲級1006 Sign In and Sign Out (25 分)

題目鏈接:https://pintia.cn/problem-sets/994805342720868352/problems/994805516654460928

題面:

1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

水題,利用了string方便的比較功能,沒有遇到什麼坑/

大致題意:

給你M條記錄,每條記錄包含了記錄id、簽到時間、簽退時間這三個數據,然後讓你輸出最早簽到和最晚簽退(即最早進來、最晚出去)的兩個人的id。

 

解題思路:

利用string方便的字符串比較機制,例如    string a="10:00:00",b="24:59:59"; 那麼a<b。【原理請自行百度】

聲明兩個string變量 start和end分別存儲最早進來和最晚出去的時間,對其賦初值,令start="24:59:59",end="00:00:00"。

然後m次循環,每次循環判斷當前簽到時間是否小於start,當前簽退時間是否大於end。如果是的話保存相應的id。代碼如下

 

#include <bits/stdc++.h>
using namespace std;
int main(){
	string in,out,s,e,id;
	string start="24:59:59",end="00:00:00";
	int m;
	cin>>m;
	while(m--){
		cin>>id>>s>>e; 
		if(s<=start){
			start=s;
			in=id;	
		}
		if(e>=end){
			end=e;
			out=id;
		}
	}
	cout<<in<<" "<<out;
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章