Milking Time -最长递增子序列变形题

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#include<set>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
struct node{
	int x,y,step;
}pp[1000009];
bool cmp(node a,node b)
{
	if(a.y == b.y)
	{
		return a.x < b.x;
	}
	return a.y < b.y;
}//快排利用贪心的思想先贪心最小的结束时间
int dp[10000009];
int main()
{
	int x,m,r;
	scanf("%d%d%d",&x,&m,&r);
	for(int i = 1;i <= m;++i)
	{
		scanf("%d%d%d",&pp[i].x,&pp[i].y,&pp[i].step);
	}
	sort(pp+1,pp+m+1,cmp);
	int min1 = 0;
	for(int i = 1;i <= m;++i)
	{
		int g =pp[i].x;
		dp[i] = pp[i].step;//啥都没有的是它本身一开始用了一个的
		for(int j = 1;j < i;++j)
		{
			if(pp[j].y + r <= g)//该前面有的结束时间小于这个的开始时间
			{
				dp[i] = max(dp[i],dp[j] + pp[i].step) ;//从可以递推的前面时间递推
			}
		}
		min1 = max(min1,dp[i]);
	}//类最长递增子序列的思路
	printf("%d\n",min1);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章