迪杰斯特拉

1003 Emergency (25 分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C
​1
​​ and C
​2
​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
​1
​​ , c
​2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C
​1
​​ to C
​2
​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C
​1
​​ and C
​2
​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4

分析:在最短的路径上获得最大的救援队数量,路径可以当成边权,救援队当成点权,用迪杰斯特拉刷一遍就出来了。num数组放的就是有多少条最短路径,w数组放最大的救援队数量

代码:

#include <iostream>
#include <cstdio> 
#include <string>
#include <cstring>
#include <vector>
using namespace std;

int n,m,c1,c2;
int dis[501],e[501][501],weight[501],w[501],way[501],num[501];
bool visit[501];
const int inf = 999999;
int main()
{ 
	cin >> n >> m >> c1 >> c2;
	for(int i = 0;i < n;i++){
		cin >> weight[i];
	} 
	fill(e[0],e[0] + 501 * 501 ,inf);
	fill(dis,dis + 501,inf);
	int a,b,c;
	for(int i = 0;i < m;i++){
		cin >> a >> b >> c;
		e[a][b] = c;
		e[b][a] = c;
	}
	dis[c1] = 0;
	w[c1] = weight[c1];
	num[c1] = 1;
	for(int i = 0;i < n;i++){
		int u = -1,minn = inf;
		for(int j = 0;j < n;j++){
			if(visit[j] == false && dis[j] < minn){
				u = j;
				minn = dis[j];
			}
		}
		if(u == -1)break;
		visit[u] = true;
		for(int v = 0;v < n;v++){
			if(visit[v] == false && e[u][v] != inf){
				if(e[u][v] + dis[u] < dis[v]){
					dis[v] = e[u][v] + dis[u];
					w[v] = weight[v] + w[u];
					num[v] = num[u];
					way[v] = u;
				}else if(e[u][v] + dis[u] == dis[v]){
					num[v] = num[v] + num[u];
					if(w[u] + weight[v] > w[v]){
						w[v] = w[u] + weight[v];
						way[v] = u;
					}
				}
			}
		}
	}
	cout << num[c2] << " " << w[c2];
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章