PAT_A1041 Be Unique (20 分)

題目:

  • Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
  • Input Specification:
    Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.
  • Output Specification:
    For each test case, print the winning number in a line. If there is no winner, print None instead.
  • Sample Input 1:
    7 5 31 5 88 67 88 17
  • Sample Output 1:
    31
  • Sample Input 2:
    5 888 666 666 888 888
  • Sample Output 2:
    None
  • 源碼參考:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int myarr[10010]={0};

int main()
{
    int N;
    int input_arr[100010];
    scanf("%d",&N);
    for(int i=0;i<N;++i)
    {
        int a;
        scanf("%d",&a);
        input_arr[i]=a;
        myarr[a]++;
    }
    for(int i=0;i<N;++i)
    {
        if(myarr[input_arr[i]]==1)
        {
            printf("%d\n",input_arr[i]);
            return 0;
        }
    }
    printf("None\n"); 
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章