PAT_A1065 A+B and C (64bit) (20 分)

題目

  • Given three integers A, B and C in [263,263][−2^{63},2^{63}], you are supposed to tell whether A+B>CA+B>C.
  • Input Specification:
    The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.
  • Output Specification:
    For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).
  • Sample Input:
    3
    1 2 3
    2 3 4
    9223372036854775807 -9223372036854775808 0
  • Sample Output:
    Case #1: false
    Case #2: true
    Case #3: false
  • 源碼參考:
//兩個負值相加可能會負溢出成正值,兩個正值相加可能會正溢出爲負值。
//long long型的存儲範圍是[-2^63,2^63-1]
#include <cstdio>
#include <iostream>
using namespace std;

int main()
{
    long long a,b,c;
    long long result;
    int T;
    bool flag;
    scanf("%d",&T);
    for(int i=0;i<T;++i)
    {
        scanf("%lld %lld %lld",&a,&b,&c);
        result=a+b;
        if(a>0 && b>0 && result<0)  //rsult<0不用等號,result溢出區間爲[-2^63,-2]
            flag=true;
        else if(a<0 && b<0 && result>=0)    //result<=0要用等號,result溢出區間[0,2^63)
            flag=false;
        else if(result>c)
            flag=true;
        else
            flag=false;
            
        if(flag==true)
            printf("Case #%d: true\n",(i+1));
        else
            printf("Case #%d: false\n",(i+1));
    }
    return  0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章