算法競賽入門經典 UVA Tree 中後序建樹+DFS

題目鏈接

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.
Input
The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.
Output
For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.
Sample Input
3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255
Sample Output
1
3
255

題目大意:
給定一棵二叉樹的中序和後序遍歷序列,找到一個葉子結點使得它到根的路徑上的權和最小,如果有多解,該葉子結點本身的權值應該儘量小。

解題思路:
中後序建樹+DFS

AC代碼:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 10005
#define INF 0x3f3f3f3f
struct node {
	node *left;
	node *right;
	int c;
}tree[maxn];//靜態內存分配數組
int num1[maxn]; int num2[maxn];
int cnt;//靜態數組中已經分配的結點個數
node *creat() {//申請一個結點空間,返回指向其的指針
	tree[cnt].left = tree[cnt].right = NULL;//初始化左右兒子爲空
	return &tree[cnt++];//返回指針,且計數器累加
}
node *build(int s1, int e1, int s2, int e2) {//由字符串的中序遍歷和後序遍歷還原樹
	node *ret = creat();//爲樹的根結點申請空間
	ret->c = num2[e2];
	int rootidx;
	for (int i = s1; i <= e1; i++) {//查找該根結點字符在中序遍歷中的位置
		if (num1[i] == num2[e2]) {
			rootidx = i;
			break;
		}
	}
	if (rootidx != s1) {//若左子樹不爲空
		ret->left = build(s1, rootidx - 1, s2, s2 + rootidx - s1 - 1);//遞歸還原左子樹
	}
	if (rootidx != e1) {//若右子樹不爲空
		ret->right = build(rootidx + 1, e1, s2 + rootidx - s1, e2 - 1);//遞歸還原右子樹
	}
	return ret;
}
int best, best_sum;
void dfs(node *t, int sum) {
	sum += t->c;
	if (t->left == NULL&&t->right == NULL) {//葉子結點
		if (sum == best_sum) {
			best = min(best, t->c);
		}
		else if (sum < best_sum) {
			best_sum = sum;
			best = t->c;
		}
		return;
	}
	if (t->left != NULL) {//左子樹不爲空
		dfs(t->left, sum);
	}
	if (t->right != NULL) {//右子樹不爲空
		dfs(t->right, sum);
	}
}
int main() {
	while (scanf("%d",&num1[0]) != EOF) {
		best = maxn; best_sum = INF;
		int k1 = 1, k2 = 0;
		while (true) {
			char ch = getchar();
			if (ch == '\n')break;
			scanf("%d", &num1[k1++]);
		}
		while (true) {
			scanf("%d", &num2[k2++]);
			char ch = getchar();
			if (ch == '\n')break;
		}
		cnt = 0;//將靜態內存空間中已經使用的結點個數初始化爲0
		node *t = build(0, k1 - 1, 0, k2 - 1);
		dfs(t, 0);
		cout << best << endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章