ZOJ1004: Anagrams by Stack(dfs + 棧模擬)

題目鏈接

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]

題意分析:

給出兩個字符串a, b 求a的入棧出棧順序, 使出棧的字符是字符串b的順序

解題思路:

in代表字符串a進棧的字符個數, out代表出棧的字符個數, 當out與字符串b的長度相等時即可輸出序列.

只有棧頂和當前b的字符相等時纔出棧.

#include <bits/stdc++.h>
using namespace std;
const int N = 120;
char a[N], b[N], ans[N];
int lena, lenb;
stack<char>s;
void dfs(int in, int out, int len)
{
	if(out==lenb) {
		for(int i=0; i<len; i++)
			printf("%c ", ans[i]);
		printf("\n");
		return ;
	}
	if(in<lena && out<lenb) {
		s.push(a[in]);
		ans[len++]='i';
		dfs(in+1, out, len);
		s.pop();
		len--;
	}
	if(!s.empty() && s.top()==b[out]) {
		char ch=s.top();
		s.pop();
		ans[len++]='o';
		dfs(in, out+1, len);
		s.push(ch);
		len--;
	}
} 
int main()
{
	while(scanf("%s%s", a, b)!=EOF)
	{
		printf("[\n");
		lena=strlen(a);
		lenb=strlen(b);
		dfs(0, 0, 0);
		printf("]\n");
	}
	return 0; 
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章